Advertisement:
Anonymous Login
04-24-2017 07:12 AM

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0000908SMF 3.0 "Saguaro"public2014-06-01 11:48
Reporterwinrules 
PrioritynoneSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Summary0000908: Child boards get marked new where their is a new post in a grand child that isn't visible.
DescriptionFor example the dev board here gets marked new when posts are made in child boards of it that we can't see.
Additional InformationParent boards don't get marked new when a direct child board gets marked new because of this code:
        // Ignore any parents on the top child level.
        //!!! Why?
        foreach ($parents as $id => $parent)
        {
            if ($parent['level'] != 0)
            {
                // If we're already doing this one as a board, is this a higher last modified?
                if (isset($lastMsg[$id]) && $lastMsg[$id_board] > $lastMsg[$id])
                    $lastMsg[$id] = $lastMsg[$id_board];
                elseif (!isset($lastMsg[$id]) && (!isset($parent_boards[$id]) || $parent_boards[$id] < $lastMsg[$id_board]))
                    $parent_boards[$id] = $lastMsg[$id_board];
            }
        }
TagsNo tags attached.
Attached Files

-Relationships
related to 0002162resolvedGrudge SMF 2.0 Boardindex shows topic subjects from hidden boards 
+Relationships

-Notes

bugnote:0004579

JayBachatero (SMF Friend)

Moved this to 2.1. This is a tricky issue and the whole logic for read/unread status needs to be looked at.

bugnote:0004907

Owdy (SMF Friend)

If this is duplicate to my issue, this has to be dealed in 2.0, not 2.1 imo . People see topic subjects from hidden board.

bugnote:0004910

SleePy (Developer)

I think it was a duplicate? Does it actually show the hidden posts or just indicates new posts?

bugnote:0004911

Owdy (SMF Friend)

It showed topic subject. "last post blah blah blah" etc. But i had big issues with upgradeing, could be related http://www.simplemachines.org/community/index.php?topic=242463.0

bugnote:0012575

Aleksi "Lex" Kilpinen (SMF Friend)

Just so you all know, I witnessed the exact same behaviour that Owdy was describing, today on a freshly upgraded 1.1.11...

A post was made to a hidden child board in "Category -> Public Board -> Hidden Child"

The forum index showed the last post made in "Hidden Child" as last post in "Public Board" and the post info was visible and clickable to all who could see "Public Board"

The "Hidden Child" was a moderator board, so this wasn't nice - I temporarely "solved" the issue by moving the "Hidden Child" to a different location, so that it wasn't a child board anymore.

bugnote:0012576

Norv (SMF Friend)

Last edited: 2010-07-18 10:31

This is an important privacy issue IMHO...
I will test as well.
Thank you Lex.

bugnote:0012580

Aleksi "Lex" Kilpinen (SMF Friend)

Norv, Bug 2162 seems to have a fix for 2.0 related to maintanence screwing up the last post ID - I'm not sure if that is the cause here, but it could be ( I did run maintancence that day, so it could have caused it. )

I also found 2 reports for 1.1 on this same issue, but for some reason they are both closed as resolved, with no fix indicated.

( Bugs 377, 222 )

bugnote:0012582

Norv (SMF Friend)

It seems you're right, rev 7364 was made on 2.0 only and not backported to 1.1.x.

bugnote:0012583

Aleksi "Lex" Kilpinen (SMF Friend)

Well, as it is a privacy issue - I would still like to see it fixed for 1.1 as well.

bugnote:0014806

emanuele (Viewer)

This is still valid in 2.1 "alpha" (at commit e6bd3bf50f086f31515a55bdabc253b4cda05311 )

TBH it doesn't seem a privacy issue: there is no actual disclosure of private info, just a user can imagine there is at least one hidden (and active) grand-child board...not really such a pain.

bugnote:0015026

Antes (Team Member)

Moved: https://github.com/SimpleMachines/SMF2.1/issues/1734
+Notes
MantisBT (Modified for SMF Intergration)[^] Copyright © 2000 - 2010 Mantis Group